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This spreadsheet plots DoubleCross™ Class-AB wingspread curves in Common Emitter mode.

The DoubleCross™ Class-AB general circuit is shown below. Emitter resistors are connected to 
common. The load is connected to the centre rail which means the power supply is floating.
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DoubleCross™ Common Emitter circuit. 
Notice emitter resistors go to common.

Approximate THD plots can be calculated directly from the wingspread equations for any power 
level and bias conditions. The effect of junction temperature are also included and an improved 
definition for optimum biasing is revealed by these equations.

This spreadsheet uses the new W-function to calculate the wingspread plots directly without 
using numerical methods. This new was first demonstrated in Thomas Banwell's IEEE 2000 
paper showing how to solve transistor circuits in large signal using the W-function. This 
spreadsheet calculates Class-AB gains to 0.03% accuracy, similar to SPICE default Reltol.

What is Class-AB DoubleCross™?
DoubleCross™ is a new Class-AB mode for power amplifier output stages for high-bias without 
Gm-doubling of standard high-bias Class-AB [footnote1,2].

The name DoubleCross™ was coined by Bob Cordell around 2015 and is explained in the 2nd 
Edition of his Power Amplifier Design book [Chapter 13, Sections 7, 8 www.cordellaudio.com].

DoubleCross™ uses 2 sets of power transistors in parallel where the 1st set “upper pair” (Q1,Q2 
above) are biased with a slightly higher DC voltage. In the circuit above “VbT” is typically 
around 50mV to 70mV. Also the 2nd set “lower pair” (Q3,Q4) are biased with a slightly lower 
DC offset of negative VbT (same amount as the 1st set but negative). 

1 Class-AB is defined differently by Douglas Self than prior to Douglas Self's books. Douglas Self defines 'Class-B' as 
'optimum bias Class-B' with a very small idle current. He defines 'Class-AB' as using a much higher bias than 
optimum bias,  what John Linsley Hood called “Class-A/AB” by but it's seldom used now. I use “Class-AB” to 
cover the whole range from low bias (Self's Class-B) to high bias (Hood's Class-A/AB). Due to the confusion from 
Self's definition we now need to define what type   of Class-AB   we are using each time it is used!!!

2  http://www.diyaudio.com/forums/solid-state/236558-amp-draw-class-vs-ab-oh-my-14.html#post3539978 Post 135 AndrewT wrote, "Is 
it possible that Douglas Self's adoption of "his" definition of Class B is quite different from everyone one else that 
I have read and this is misleading you?" [emphasis added]
http://www.diyaudio.com/forums/solid-state/236558-amp-draw-class-vs-ab-oh-my-14.html#post3540572 Post 140 O'Connor wrote, 
"Everyone has generally considered the "optimal class-B" biasing to be Class-AB until Doug presented his 
definition. Truly, that is what confuses many about the A,B,AB debate." [IH emphasis added]
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This achieves some magic when VbT is just the right amount for the ordinary bias Vb. 

What magic? Crossover distortion can be nulled out over a relatively large Class-A crossover 
region which can cover the first 1 to 2 watts in a 100W amp. Recall the 1st watt covers the 
main power range when listening to music, even for a 100W amplifier, so increasing the low 
distortion power range up to the first few watts with DoubleCross™ is a very welcome 
improvement over standard bias Class-AB which covers only the first 50mW in Class-A 
[footnote3]. 

Effectively DoubleCross™ fixes the long-standing problem of “gm-doubling” [footnote4] – we 
can now operate at a relatively high bias current without the bad side effects of gm-doubling.

A secondary advantage with DoubleCross™ is the power transistors run closer to their worst 
case dissipation [footnote5]. It means troubling thermal variations are significantly reduced so 
the bias is more stable than standard Class-AB amplifier output stages [footnote6]. 

One practical benefit of DoubleCross™ is it gives lower distortion before applying any feedback. 
Lower distortion before applying any feedback makes it easier to design good sounding 
transistor amplifiers that are less likely to oscillate and be destroyed [footnote7].

Using the spreadsheet
After downloading and running the spreadsheet you can see the plots change several input 
values in RED such as RE14, RE23, and transistor Tj, ISn & ISp and BetaN & BetaP. 

After entering your new value you can watch the updated plots immediately. Spin buttons can 
be added to make changes a lot easier with mouse clicks (see Appendix).

The idle bias point for each pair is set by “Kb1” for the NPN and “Kb2” for the PNP. A Kb=1 
(1 Vt of bias) corresponds to 1·Vt of voltage across the source resistors which is Olivers criteria 
for “optimum bias”. The bias generator voltages are displayed along with the bias currents.

The “tension current” (see circuit) is set by “KbT”. The Kb is the number of Vt's added to the 
datum bias given no tension current (KbT=0). The bias voltages are displayed on Sheet1. 

Tension bias KbT number is typically 2-3·Vt (3×Vt is about 80mV at 27°C) giving an idle 
current of about 300mA. 

To help visualise DoubleCross™ notice what happens when KbT is set to zero; both pairs have 
the same idle current of about 60mA set by Kb (giving Vb) and 60mA is about the optimum 
bias for single pairs at 27°C. 

Then increasing KbT from 0 to 3·Vt (about 80mV at 27°C) we see the Class-A region get wider 
while the Gm is almost perfectly 'flat band' – so distortion remains very low in this flat region. 
With higher KbT the flat Gm Class-A region is no longer flat so distortion increases. 

With KbT around 3·Vt we get the widest possible low distortion Class-A region 'flat band'. This 
is some of the magic of DoubleCross™. This spreadsheet can be configured to allow the Solver 
add-in utility to automatically search for the best values for KbT, Kb and RE14 to give the 
flattest Class-A band and therefore the lowest THD in the Class-A band. A section below covers 
adding Solver.

3 Standard Class-AB with optimum bias of 50mA Class-A band is ±0.1A or ±0.8Vpk or P=½×0.8^2/8 = 40mW.
4 With a much higher bias than optimum, when crossing the widened Class-A region we get bad crossover distortion.
5 When the music is turned up to just before clipping the amplifiers dissipation peaks to about 1/3rd the maximum 

sinewave output power of the amplifier. DoubleCross™ high idle dissipation is still less than the worst case 
dissipation. So DoubleCross™ does not increase the heatsink size. DoubleCross™ higher idle dissipation brings the 
idle junction temperatures closer to worst case junction temperatures, so there's less unction temperature changes.

6 Bias stability with changing junction temperature is a serious design issue that has not been solved satisfactorily in 
standard output stages because the junction temperature cannot be monitored directly. Monitoring the case 
temperature is the next best thing using a “Vbe multiplier” transistor. But there is s significant time lag of 10-30 
seconds when the power dissipation changes but the bias sensor lags creating Thermal Lag Distortion (TLD), 
something not measured or quoted – maybe because we can't fix it so why even study and quantify it? [HFN Oct 04]

7 My guess is 90% of high feedback transistor amplifier design effort goes into getting it stable. When transistor amps 
oscillate, usually in the ultrasonic region, the output stage's cross-conduction overheats and blows the OP transistors.
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How the spreadsheet works
The large signal equation for transistor current is a modified form of Ohm's law using voltage 
“Vt” (26mV at room temperature) as the base voltage across a series resistor Rs and this 
voltage “Vt” is scaled by the W function which depends on the input voltage as below:

I =
Vt×W [e

(Vin−Vk
Vt )]

Rs
 where Vk = Vt×ln( Vt

Is⋅Rs)
Vin is the transistor Vbe without series resistance. Vk is the knee voltage mentioned above and 
for silicon power transistors it is around 550mV to get collector current to the 10mA range. 

Effectively, the W function scales voltage “Vt” by how much of the base voltage gets through to 
the resistance “Rs” where the diode is fed by Vin and Rs is connected to common – forming 
the equivalent of a voltage divider. It's a 21st century Ohm's law for large signal circuits.

Calculating gain directly 

Transconductance Gm of a transistor is the slope ∆Ic/∆Vbe. It can be found by the difference 
of collector current for a small change in Vbe giving a numerical value at the operating point. 

The W-function can be differentiated giving the Gm gain in general as below:

d I
d Vin

=
1

Rs
×

W [e
(Vin−Vk

Vt )]
1+W [e

(Vin−Vk
Vt )]

 

This is powerful since we can analyse transistor Gm gains in general terms – we don't have to 
plug in component values or use an operating point as previously using small-signal analysis. 
It unlock a new approach for designing amplifiers. For example, for audio amplifiers it is 
variations in gain (or the nonlinearity) that generates distortion. Since we can calculate the 
gain in general it is now possible to find the distortion as a general equation without having to 
plug in specific values for the components and bias point. For example, we can also write 
simple equations for the percent distortion for the 2nd and 3rd harmonics in general terms for 
our transistor circuits. 

In this spreadsheet the input voltage is stepped over ±80 increments allowing an approximate 
THD value at any particular input level (or power output) – it is done by a running average of 
gain deviation [footnote8] (more below).

Plotting Gm's and currents against Vin 

An equation solution for plotting Gm's and currents given Vin for the Common Emitter stage is 
relatively straight forward using the W-function once the circuit is converted to two D+R 
equivalent circuits [footnote9].

The spreadsheet assumes needs value for the supply voltage so the ±80 rows can be assigned 
voltage increments automatically. An estimate of the maximum input voltage (Vxmax) is 
calculated using a simple approximation of the voltage gain. Then Vin can be calculated for 
each step of Vx using Vin=Vx+(Ic1+Ic2)×RL. The spreadsheet then uses a scatter X-Y plot 
with Vin for the X-axis.

Spreadsheet preset values 

The preset 'Is' value is 5e-12A for Q1 like the Cordell model for the MJL3281 (NPN) and 
7e-12A for the MJL1302 (PNP) which are a popular RET (Ring Emitter Transistor) for audio 
power amplifiers. One pair can provide 50W into 8 ohms or 100W into 4 ohms from a supply 
voltage of around ±35V.

8 It works similar to Baxanadall's “total difference” method where the distortion can be extracted by nulling out the 
fundamental, then taking the RMS of the residual distortion and dividing by the fundamentals RMS.[WW 1977 p63]

9 The LTspice files can be download as a PDF then converted to .asc – the steps given in a help PDF (or email above).
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The emitter resistances RE1 and RE2 are set at 0.22 ohms which is a safe resistance for a 50W 
audio amplifier [footnote10]. Higher power amplifiers typically use 0.22 ohms with multiple 
parallel transistors – too low Rs values can lead to thermal runaway from current hogging 
when paralleling transistors. The preset 'Tj' value is 27° which is the default used by LTspice.

Plotting THD against Vin 

Distortion can be estimated from the total Gm of a follower by first calculating the average 
deviation from the average gain for a given peak input voltage. This works because the 
distortion component is the difference between the average gain and the THD is the RMS of 
the deviation divided by the RMS of the signal [footnote11]. 

There are 80 increments of input voltage and each cell uses indirect addressing based on the 
increment number [footnote12] and this gives a running average from Vin=0 up to any input 
voltage used:

=AVEDEV(INDIRECT("AN93:"&ADDRESS(CELL("row";AN$93)+Inc;CELL("COL";AN94)))) 
This metric requires a scaling factor of around 1/3 with large input levels but for small levels 
the scale factor needs to approach 1. This metric is not very accurate with a scaling factor. 

An improved metric is to repeat the AVEDEV(…) function, yes, it is done twice [footnote13] – then 
the THD follows the LTspice THD values quite accurately without post scaling. Bravo!

Spreadsheet THD [Red] Points [blue] THD from LTspice for the same circuit settings

The plot above from the spreadsheet shows THD along with several points where the THD has 
been found with LTspice for the exact same circuit settings. 

Interestingly, the THD of only 0.01% up to 2 watts is low enough to make crossover distortion 
inaudible (to me) with speakers having good sensitivity (≥90dB/W/m) [footnote14]. 

This suggests it is possible to make a Common Emitter DoubleCross™ amplifier without any 
negative feedback and with sufficient voltage gain from the output stage to be fed from a 
suitable buffer/follower to give enough current (say 100mA peak) to drive the power 
transistors [footnote15]. With Common Emitter the output impedance is high with no feedback.

10 MJL3281/1302 type transistors include some internal ohmic resistance of around 50mΩ. So enter 270mΩ in SS.
11 It was found that the rectified average using the AVEDEV functions was almost identical to the RMS calculation so 

the AVEDEV function was used to simplify the calculations.
12 The “Inc” value is label that sets the number of rows to do the calculation where Inc=0 when Vin=0 and 80 rows are 

used to cover the full input voltage swing and the default maximum input swing is ±40V so 160 rows are used in 
this spreadsheets to give the smallest step of 0.5V (or 7mW into 8 ohms).

13 A companion spreadsheet (PAK411 DoubleCross CE) shows the double AVEDEV(…) metric is a measure of the 
flatness of the wingspread plot from Vin=0 up to the Vin level used

14 See my listening tests for crossover distortion reported in Linear Audio Vol.4 and 0.03% THD was my threshold.
15 A buffer/follower could be a medium current ±5V opamp. Rising THD above 2W is not significant with music 

because peaks above 10W are infrequently – and with soft clipping starting above 30W a THD of 1% is not an issue. 
No feedback CE output impedance is naturally high–suitable for current driven speakers for lower distortion☺ [ref].
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BJT Temperature effects 

Temperature is entered as “Tj” in °C. Temperature changes the thermal voltage Vt and the 
effective “IS” values for Q1 and Q2. 

Thermal voltage Vt = KT/q where K is Boltzman's constant and q is the electrons charge and T 
is temperature in Kelvin. 

Saturation current with temperature: IS=IS 0( T
T 0)

XTI

exp( EG
K /q( 1

T 0

−
1
T ))  where T0 is the 

reference temperature of the model (T0 is Tnom in SPICE), XTI is the power-law for IS, and 
“EG” is the exponential voltage constant – typically 1.11V (default value in SPICE). In the 
spreadsheet “IsQ1TF” is the ratio Is/Is0 in the above equation – IsQ1TF is the Temperature 
Factor for scaling Is0. Looking at the value of IsQ1TF when changing Tj in the spreadsheet you 
can see how much the reference IS is being scaled at that temperature. For example, when 
Tj=77°C (50°C above reference of 27°C) the value of IsQ1TF is about 500, or IS at 27°C is 
being scaled by a factor of 500! which is a huge increase for typical power transistors typically 
operating in this temperature range.

Now with IS0 being scaled by 500 times more than at ambient we would expect transistors to 
be too temperature sensitive to be much use. But we know there's not a serious problem with 
such large changes in the IS value because the gain (Gm) of the transistor doesn't actually 
change by that much since, recall, Gm = Ic/Vt and is not dependent on the IS value at all. 

With Gm = Ic/Vt the Vt value changes a relatively small amount when Tj goes from 27°C to 
77°C (it's 26mV to 26*(77+273)/(27+273) or 26*350/300=26*1.167=30.3mV) only a 17% 
decrease in Gm when we keep Ic constant. To have a constant Gm when the transistors 
temperature increases we need to also increase Ic by +17% with 50°C increase in 
temperature, or increase Ic at the rate of about +0.3%/°C.

If we can change the bias voltage to the transistors when the junction temperature changes we 
will end up with a minuscule increase in the transistors Gm's with temperature changes. That's 
how come our transistor amplifiers can be made to work over quite large temperature changes 
despite transistor IS values changing by huge amounts.

The Table below for DoubleCross™ Common Emitter changing temperature from 27°C 77°C.→
Tj [°C] Vt [mV] Vk23 [mV] Vk14 [mV] Vb23* [mV] Vb14* [mV] Io23 [mA] Io14 [mA]

27 25.86 618 616 611 616 4.31 291

77 30.17 537 535 529 535 5.00 339.4

diff 4.31 81 81 82 81 0.7 48

Temp Co +0.08mV/°C 
or +0.3%/°C

-1.62mV/°C 
or -0.28%/°C

-1.62mV/°C
or -0.28%/°C

 -1.64mV/°C 
or -0.28%/°C

 -1.62mV/°C 
or -0.28%/°C

+0.014mA/°C 
~+0.3%/°C

+1mA/°C 
~+0.3%/°C

*Kb=-0.27, KbT=3.00 and then Vb=Vk+Kb×Vt  and  VbT=KbT×Vt. 

BTW the temp. co for a typical BJT is -2.2mV/°C which is about -0.33%/°C (at Tj~27°C). In 
the table above the bias voltage temp. co for Vk and Vb are -1.6mV/°C or 0.28%/°C (at 
Tj~50°C). This is with SPICE model parameters for the MJL3281 (NPN) which agree with the 
datasheet. Also the table shows that when the bias voltage changes at -1.6mV/°C or 
0.28%/°C by using the calculated knee voltage (Vk) from first principles, then the idle current 
increases at +0.3%/°C which ensures the wingspread plot remains essentially the same (same 
Gm) and the THD does not alter when Tj changes over such a large range. 

Interestingly, the temp. co for Vt of +0.3%/C is the same as the bias current temp. co of 
+0.3%/C – that's when the bias voltage changes at -1.6mV/°C or -0.28%/°C by using the 
calculated knee voltage (Vk) from first principles to give the same wingspread curve with 
changing temperature. 

Interesting also because Douglas Self also found that the idle current should increase slightly, 
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at the same rate as the Thermal voltage Vt [ref?], as implied by Oliver's criterion [footnote16], 
where Vt increases with temperature at about +0.3%/C at room temperatures or slightly 
above this, therefore the idle current should increase at about +0.3%/°C with junction 
temperature, contrary to common belief that the idle current should be as constant s possible 
with temperature. This spreadsheet puts a nail in that wrong belief using first principles maths.

The plot below for DoubleCross™ Common Emitter shows gain change from 27°C to 77°C.

DoubleCross™ Common Emitter change in gain for Tj 27°C to 77°C [Red 27°C]. 

Notice the change in gain of the Common Emitter stage is vanishingly small when using the 
calculated knee voltage (Vk) from first principles. It gives the same wingspread curve with 
changing temperature and then increasing the additional bias from Vk by Vt's temp. co of 
about +0.3%/°C with junction temperature. It means thermal effects on the THD could be 
virtually eliminated by changing the bias voltages with Tj in the same way the calculations in 
this spreadsheet. 

Any queries are welcome (use link above).

------------------------- ------------------------

Appendix:
Using Solver to find the optimum bias to minimise distortion 
One of the useful features of a spreadsheet that can estimate THD reasonably well is to use a 
nonlinear Solver algorithm to search for the best bias voltages. A nonlinear Solver algorithm 
can also search for the best value of Re14 as well as the best bias voltages. To try and find the 
best value of RE14 as well as the best bias voltages for a DoubleCross™ circuit would take many 
hours when it can be done in a minute with the spreadsheets nonlinear Solver algorithm. Also 
a DoubleCross™ circuit involving more parallel pairs can be optimised for the best best value of 
RE as well as the best bias voltages which becomes unmanageable in LTspice.

The PAK411 spreadsheet has been written in OpenOffice (I use version 3.1.4) and also 
converted to Excel for a wider audience. OpenOffice default Solver is a linear solver and is of 
no use for this spreadsheet, so a nonlinear Solver algorithm needs to be downloaded, eg I 
used the one from Sun here https://extensions.openoffice.org/project/NLPSolver ver0.9 dated 2009 file 
“nlpsolver.oxt”). Documentation is here https://wiki.openoffice.org/wiki/NLPSolver. 

To add to OpenOffice Calc first open the spreadsheet and set the Java Runtime Environment directory if it is not 
already defined; use Tools>Options>OpenOffice.org>Java Tick Use Runtime Environment then Add>Program 
Files>Java>jre6 (or later) then it should show the Vendor and Version, then OK. Next Tools>Extension Manager>Add> 
Goto location of add-in and select it. After it has opened you need to accept the terms of use then it's done. Go to 
Tools>Solver>Options>Solver Engine and choose SCO Evolutionary Engine (or DEPS Evolutionary Engine). Set the 
Solver>Target Cell (eg Sheet1 $P$3 or $P$4 or $P$5), Optimise Minimum, By Changing cells $D$12:$D$13   or   

16 Oliver's criterion where biasing effectively gives one Vt on the emitter resistors (plus associated parasitic emitter 
and base resistances) and Vt increases with junction temperature at about 0.3%/°C.
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$D$12:$D$13:$D$4  and add some constraints for these (eg $D$12≤0, $D$13≤5, $D$13≥0, $D$4≥0.15). Drag Solver 
window down to view the Gm plot as it iterates (it can take 1-2 minutes). To start click Solve. Accept changes and 
record final values or Restore to original. Done. 

Tip 2:

To add to a spin box eg  to OpenOffice Calc first download the file with a spin button [spinbutton.ods]. 
Open the spin button spreadsheet and copy the button. Open you spreadsheet and place the cursor on the cell next to 
the one you would like to increment (for D3 place the cursor on 3) and paste. Click the “Design Mode on/off” icon   
(to enable the toolbar: View>Toolbars>Form Controls). Right click and select Control to view the properties. To 
change orientation to horizontal. Set Min value, Max value, Default, Increment (is only integers). Data tab and set 
Linked Cell to E3 (this example). Design Mode on/off to accept values and watch D3 value change when clicking the 
spin button (set the alignment of E3 to Right justify to see the number. To get cell D3 to change enter an equation in D3 
like “=E3/100” for increments of 0.01 when E3 is set to increment by 1. Choose the Max value–Min value to suit your 
application with the divisor value.

Using Solver to minimise wingspread gain wobbles 
Using Solver to minimise THD from the first AVEDEV(…) metric does not minimise gain wobbles 
in the lower power flattish gain region (Left plot below). These gain wobbles are minimised 
using the AVEDEV of AVEDEV metric. Solver looks for both minimum THD and minimum gain 
wobbles – in other words the flattest possible gain curve with the lowest distortion. Solver 
reduced THD by a factor of 10 compared to the best attempt manually using LTspice stepping.

  
[Left] Wingspread plot before using Solver. THD 0.0017% at 2W

[Right] After using Solver to minimise wobbles. THD 0.0002% or 2ppm at 2W.

Q and A 

1.  Q. 

A. 

2. Q. [add]
A. [add]
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